Polkadot Asset Hub Mainnet Network - Block Production Stalled

Incident Report for All That Node

Resolved

This incident has been resolved.
Posted Jun 12, 2026 - 09:52 UTC

Investigating

The Polkadot Asset Hub Mainnet has stopped producing blocks and is currently halted at checkpoint 16,946,490.

This is a global network issue. While our AllThatNode infrastructure remains fully operational, new transactions and data updates are temporarily paused due to the mainnet halt. We will provide updates as more information becomes available.
Posted Jun 12, 2026 - 09:37 UTC
This incident affected: Polkadot AssetHub (polkadotassethub-mainnet-full).